1 files changed, 27 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index d1603b5d8b..f4d6f0c6bb 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,5 +1,30 @@
[tool.towncrier]
package = "synapse"
- filename = "CHANGES.rst"
+ filename = "CHANGES.md"
directory = "changelog.d"
- issue_format = "`#{issue} <https://github.com/matrix-org/synapse/issues/{issue}>`_"
+ issue_format = "[\\#{issue}](https://github.com/matrix-org/synapse/issues/{issue}>)"
+
+ [[tool.towncrier.type]]
+ directory = "feature"
+ name = "Features"
+ showcontent = true
+
+ [[tool.towncrier.type]]
+ directory = "bugfix"
+ name = "Bugfixes"
+ showcontent = true
+
+ [[tool.towncrier.type]]
+ directory = "doc"
+ name = "Improved Documentation"
+ showcontent = true
+
+ [[tool.towncrier.type]]
+ directory = "removal"
+ name = "Deprecations and Removals"
+ showcontent = true
+
+ [[tool.towncrier.type]]
+ directory = "misc"
+ name = "Internal Changes"
+ showcontent = true
|