2 files changed, 7 insertions, 2 deletions
diff --git a/debian/build_virtualenv b/debian/build_virtualenv
index dd97e888ba..5fc817b607 100755
--- a/debian/build_virtualenv
+++ b/debian/build_virtualenv
@@ -31,12 +31,11 @@ case $(dpkg-architecture -q DEB_HOST_ARCH) in
esac
# Manually install Poetry and export a pip-compatible `requirements.txt`
-# We need a Poetry pre-release as the export command is buggy in < 1.2
TEMP_VENV="$(mktemp -d)"
python3 -m venv "$TEMP_VENV"
source "$TEMP_VENV/bin/activate"
pip install -U pip
-pip install poetry==1.2.0
+pip install poetry==1.3.2
poetry export \
--extras all \
--extras test \
diff --git a/debian/changelog b/debian/changelog
index c4be6ac67a..ee7439f38f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+matrix-synapse-py3 (1.75.1) UNRELEASED; urgency=medium
+
+ * Use Poetry 1.3.2 to manage the bundled virtualenv included with this package.
+
+ -- Synapse Packaging team <packages@matrix.org> Tue, 17 Jan 2023 15:08:00 +0000
+
matrix-synapse-py3 (1.75.0) stable; urgency=medium
* New Synapse release 1.75.0.
|