summary refs log tree commit diff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/NEWS12
-rwxr-xr-xdebian/build_virtualenv6
-rw-r--r--debian/changelog16
-rw-r--r--debian/control9
4 files changed, 34 insertions, 9 deletions
diff --git a/debian/NEWS b/debian/NEWS
index 8f0d9d0acf..7b032d86bd 100644
--- a/debian/NEWS
+++ b/debian/NEWS
@@ -1,7 +1,8 @@
 matrix-synapse-py3 (0.34.0) stable; urgency=medium
 
   matrix-synapse-py3 is intended as a drop-in replacement for the existing
-  matrix-synapse package. The replacement should be relatively seamless,
+  matrix-synapse package. When the package is installed, matrix-synapse will be
+  automatically uninstalled. The replacement should be relatively seamless,
   however, please note the following important differences to matrix-synapse:
 
   * Most importantly, the matrix-synapse service now runs under Python 3 rather
@@ -9,12 +10,17 @@ matrix-synapse-py3 (0.34.0) stable; urgency=medium
 
   * Synapse is installed into its own virtualenv (in /opt/venvs/matrix-synapse)
     instead of using the system python libraries. (This may mean that you can
-    remove a number of old dependencies with `apt-get autoremove`).
+    remove a number of old dependencies with `apt autoremove`).
+
+  * If you have previously manually installed any custom python extensions
+    (such as matrix-synapse-rest-auth) into the system python directories, you
+    will need to reinstall them in the new virtualenv. Please consult the
+    documentation of the relevant extensions for further details.
 
   matrix-synapse-py3 will take over responsibility for the existing
   configuration files, including the matrix-synapse systemd service.
 
-  Beware, however, that `apt-get purge matrix-synapse` will *disable* the
+  Beware, however, that `apt purge matrix-synapse` will *disable* the
   matrix-synapse service (so that it will not be started on reboot), even
   though that service is no longer being provided by the matrix-synapse
   package. It can be re-enabled with `systemctl enable matrix-synapse`.
diff --git a/debian/build_virtualenv b/debian/build_virtualenv
index 61ffb13192..83346c40f1 100755
--- a/debian/build_virtualenv
+++ b/debian/build_virtualenv
@@ -33,7 +33,8 @@ dh_virtualenv \
     --preinstall="lxml" \
     --preinstall="mock" \
     --extra-pip-arg="--no-cache-dir" \
-    --extra-pip-arg="--compile"
+    --extra-pip-arg="--compile" \
+    --extras="all"
 
 # we copy the tests to a temporary directory so that we can put them on the
 # PYTHONPATH without putting the uninstalled synapse on the pythonpath.
@@ -41,8 +42,7 @@ tmpdir=`mktemp -d`
 trap "rm -r $tmpdir" EXIT
 
 cp -r tests "$tmpdir"
-cd debian/matrix-synapse-py3
 
 PYTHONPATH="$tmpdir" \
-    ./opt/venvs/matrix-synapse/bin/python \
+    debian/matrix-synapse-py3/opt/venvs/matrix-synapse/bin/python \
         -B -m twisted.trial --reporter=text -j2 tests
diff --git a/debian/changelog b/debian/changelog
index 040c8e7cd3..921f7021d8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,19 @@
+matrix-synapse-py3 (0.34.1+1) stable; urgency=medium
+
+  * Remove 'Breaks: matrix-synapse-ldap3'. (matrix-synapse-py3 includes
+    the matrix-synapse-ldap3 python files, which makes the
+    matrix-synapse-ldap3 debian package redundant but not broken.
+
+ -- Synapse Packaging team <packages@matrix.org>  Wed, 09 Jan 2019 15:30:00 +0000
+
+matrix-synapse-py3 (0.34.1) stable; urgency=medium
+
+  * New synapse release 0.34.1.
+  * Update Conflicts specifications to allow installation alongside our
+    matrix-synapse transitional package.
+
+ -- Synapse Packaging team <packages@matrix.org>  Wed, 09 Jan 2019 14:52:24 +0000
+
 matrix-synapse-py3 (0.34.0) stable; urgency=medium
 
   * New synapse release 0.34.0.
diff --git a/debian/control b/debian/control
index 552a81dcb0..634f04284a 100644
--- a/debian/control
+++ b/debian/control
@@ -5,7 +5,7 @@ Maintainer: Synapse Packaging team <packages@matrix.org>
 Build-Depends:
  debhelper (>= 9),
  dh-systemd,
- dh-virtualenv (>= 1.0),
+ dh-virtualenv (>= 1.1),
  lsb-release,
  python3-dev,
  python3,
@@ -13,12 +13,15 @@ Build-Depends:
  python3-pip,
  python3-venv,
  tar,
-Standards-Version: 3.9.5
+Standards-Version: 3.9.8
 Homepage: https://github.com/matrix-org/synapse
 
 Package: matrix-synapse-py3
 Architecture: amd64
-Conflicts: matrix-synapse
+Provides: matrix-synapse
+Breaks:
+ matrix-synapse (<< 0.34.0-0matrix2),
+ matrix-synapse (>= 0.34.0-1),
 Pre-Depends: dpkg (>= 1.16.1)
 Depends:
  adduser,