summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorDavid Robertson <davidr@element.io>2022-03-04 11:58:49 +0000
committerGitHub <noreply@github.com>2022-03-04 11:58:49 +0000
commit4aeb00ca20a0d9dbb2a104591aca081c723eb6d9 (patch)
tree8029510b249bc8019cb28d209656af6fd6041ba7 /setup.py
parentSpread out sending device lists to remote hosts (#12132) (diff)
downloadsynapse-4aeb00ca20a0d9dbb2a104591aca081c723eb6d9.tar.xz
Move synctl into `synapse._scripts` and expose as an entrypoint (#12140)
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py

index 318df16766..439ed75d72 100755 --- a/setup.py +++ b/setup.py
@@ -155,6 +155,7 @@ setup( # Application "synapse_homeserver = synapse.app.homeserver:main", "synapse_worker = synapse.app.generic_worker:main", + "synctl = synapse._scripts.synctl:main", # Scripts "export_signing_key = synapse._scripts.export_signing_key:main", "generate_config = synapse._scripts.generate_config:main", @@ -177,6 +178,5 @@ setup( "Programming Language :: Python :: 3.9", "Programming Language :: Python :: 3.10", ], - scripts=["synctl"], cmdclass={"test": TestCommand}, )