summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorreivilibre <oliverw@matrix.org>2021-10-11 16:34:31 +0100
committerGitHub <noreply@github.com>2021-10-11 16:34:31 +0100
commit5e29d417fc5933e26ba85a40c298d46b09580330 (patch)
treeb58a24bfcd35792213098992ba67930ad0fadf7c /setup.py
parentPass through `SynapseError`s that are raised from experimental `check_event_a... (diff)
downloadsynapse-5e29d417fc5933e26ba85a40c298d46b09580330.tar.xz
Include the requirements for [mypy,lint] in [dev] (#11034)
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py23
1 files changed, 14 insertions, 9 deletions
diff --git a/setup.py b/setup.py

index f8b4487bc1..220084a49d 100755 --- a/setup.py +++ b/setup.py
@@ -103,15 +103,6 @@ CONDITIONAL_REQUIREMENTS["lint"] = [ "flake8", ] -CONDITIONAL_REQUIREMENTS["dev"] = CONDITIONAL_REQUIREMENTS["lint"] + [ - # The following are used by the release script - "click==7.1.2", - "redbaron==0.9.2", - "GitPython==3.1.14", - "commonmark==0.9.1", - "pygithub==1.55", -] - CONDITIONAL_REQUIREMENTS["mypy"] = [ "mypy==0.910", "mypy-zope==0.3.2", @@ -130,6 +121,20 @@ CONDITIONAL_REQUIREMENTS["mypy"] = [ # parameterized_class decorator was introduced in parameterized 0.7.0 CONDITIONAL_REQUIREMENTS["test"] = ["parameterized>=0.7.0"] +CONDITIONAL_REQUIREMENTS["dev"] = ( + CONDITIONAL_REQUIREMENTS["lint"] + + CONDITIONAL_REQUIREMENTS["mypy"] + + CONDITIONAL_REQUIREMENTS["test"] + + [ + # The following are used by the release script + "click==7.1.2", + "redbaron==0.9.2", + "GitPython==3.1.14", + "commonmark==0.9.1", + "pygithub==1.55", + ] +) + setup( name="matrix-synapse", version=version,