summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorMaximilian Bosch <maximilian@mbosch.me>2021-11-30 17:52:45 +0100
committerGitHub <noreply@github.com>2021-11-30 16:52:45 +0000
commit42bf0204635213e2c75188b19ee66dc7e7d8a35e (patch)
treed7d04296b0ec8a15e198eae800a84ceb1ee262f5 /setup.py
parentBundle relations of relations into the `/relations` result. (#11284) (diff)
downloadsynapse-42bf0204635213e2c75188b19ee66dc7e7d8a35e.tar.xz
Expose worker & homeserver as entrypoints in `setup.py` (#11449)
Co-authored-by: reivilibre <oliverw@matrix.org>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 6 insertions, 0 deletions
diff --git a/setup.py b/setup.py

index ad99b3bd2c..2c6fb9aacb 100755 --- a/setup.py +++ b/setup.py
@@ -152,6 +152,12 @@ setup( long_description=long_description, long_description_content_type="text/x-rst", python_requires="~=3.6", + entry_points={ + "console_scripts": [ + "synapse_homeserver = synapse.app.homeserver:main", + "synapse_worker = synapse.app.generic_worker:main", + ] + }, classifiers=[ "Development Status :: 5 - Production/Stable", "Topic :: Communications :: Chat",