summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorErik Johnston <erik@matrix.org>2021-04-13 11:51:10 +0100
committerGitHub <noreply@github.com>2021-04-13 11:51:10 +0100
commitc1dbe84c3dcd643f4acedba346046b25a117e3c3 (patch)
treed1a3cccb7ffc5c3f7fe3a64ff20952f9b58a0225 /setup.py
parentBump black configuration to target py36 (#9781) (diff)
downloadsynapse-c1dbe84c3dcd643f4acedba346046b25a117e3c3.tar.xz
Add release helper script (#9713)
Co-authored-by: Richard van der Hoff <1389908+richvdh@users.noreply.github.com>
Co-authored-by: Andrew Morgan <1342360+anoadragon453@users.noreply.github.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/setup.py b/setup.py

index 4530df348a..e2e488761d 100755 --- a/setup.py +++ b/setup.py
@@ -103,6 +103,13 @@ CONDITIONAL_REQUIREMENTS["lint"] = [ "flake8", ] +CONDITIONAL_REQUIREMENTS["dev"] = CONDITIONAL_REQUIREMENTS["lint"] + [ + # The following are used by the release script + "click==7.1.2", + "redbaron==0.9.2", + "GitPython==3.1.14", +] + CONDITIONAL_REQUIREMENTS["mypy"] = ["mypy==0.812", "mypy-zope==0.2.13"] # Dependencies which are exclusively required by unit test code. This is