summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorDavid Baker <dave@matrix.org>2015-01-30 17:15:39 +0000
committerDavid Baker <dave@matrix.org>2015-01-30 17:15:39 +0000
commit9ccfdfcd7cc15f5c944670e6b6bcfe74090763f1 (patch)
tree414424e44b62855f1c1ff1449522a6948a744ddb /setup.py
parentadd generate config instruction to the HS setup part (diff)
downloadsynapse-9ccfdfcd7cc15f5c944670e6b6bcfe74090763f1.tar.xz
Add twisted to setup requires so it gets processed before setuptools_trial
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index abccca0f2c..eb1d17c25f 100755
--- a/setup.py
+++ b/setup.py
@@ -50,6 +50,7 @@ setup(
         "https://github.com/matrix-org/matrix-angular-sdk/tarball/v0.6.0/#egg=matrix_angular_sdk-0.6.0",
     ],
     setup_requires=[
+        "Twisted==14.0.2", # Here to override setuptools_trial's dependency on Twisted>=2.4.0
         "setuptools_trial",
         "setuptools>=1.0.0", # Needs setuptools that supports git+ssh.
                              # TODO: Do we need this now? we don't use git+ssh.