summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorAndrew Morgan <1342360+anoadragon453@users.noreply.github.com>2020-06-01 19:45:01 +0100
committerGitHub <noreply@github.com>2020-06-01 19:45:01 +0100
commit25e2d193e36e8fd8864dd06e2e9d9dd95bf635fe (patch)
tree3f7f9e115061d8c1585e5cc38d60116da67279be /setup.py
parentFix a bug in automatic user creation with m.login.jwt. (#7585) (diff)
downloadsynapse-25e2d193e36e8fd8864dd06e2e9d9dd95bf635fe.tar.xz
Advertise Python 3.8 support in setup.py (#7602)
Synapse supports Python 3.8. We've been using it in CI for a while now.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 5ce06c8987..54ddec8f9f 100755
--- a/setup.py
+++ b/setup.py
@@ -114,6 +114,7 @@ setup(
         "Programming Language :: Python :: 3.5",
         "Programming Language :: Python :: 3.6",
         "Programming Language :: Python :: 3.7",
+        "Programming Language :: Python :: 3.8",
     ],
     scripts=["synctl"] + glob.glob("scripts/*"),
     cmdclass={"test": TestCommand},