summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorMark Haines <mark.haines@matrix.org>2015-02-10 18:25:54 +0000
committerMark Haines <mark.haines@matrix.org>2015-02-10 18:25:54 +0000
commiteab141ee676c87f6d1ca3d853e3f9ef9d49e28ca (patch)
treeab7407cf2c9f578c605072576d16e2c2393a667e /setup.py
parentMerge branch 'develop' into single_source_version_and_dependencies (diff)
downloadsynapse-eab141ee676c87f6d1ca3d853e3f9ef9d49e28ca.tar.xz
Rename path to path_segments to make it clearer that it is a list
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index cc7a3f5b69..2d812fa389 100755
--- a/setup.py
+++ b/setup.py
@@ -21,18 +21,18 @@ from setuptools import setup, find_packages
 here = os.path.abspath(os.path.dirname(__file__))
 
 
-def read_file(path):
+def read_file(path_segments):
     """Read a file from the package. Takes a list of strings to join to
     make the path"""
-    file_path = os.path.join(here, *path)
+    file_path = os.path.join(here, *path_segments)
     with open(file_path) as f:
         return f.read()
 
 
-def exec_file(path):
+def exec_file(path_segments):
     """Execute a single python file to get the variables defined in it"""
     result = {}
-    code = read_file(path)
+    code = read_file(path_segments)
     exec(code, result)
     return result