summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorOlivier Wilkinson (reivilibre) <oliverw@matrix.org>2021-10-08 17:11:14 +0100
committerOlivier Wilkinson (reivilibre) <oliverw@matrix.org>2021-10-08 17:11:14 +0100
commitc576598a6834c59e7e6e51eb72c2967b00762666 (patch)
tree84a1b9228978dfd48a71469f935c1e04e14a1b17 /setup.py
parentAnnotate synapse.storage.util (#10892) (diff)
downloadsynapse-c576598a6834c59e7e6e51eb72c2967b00762666.tar.xz
Include the requirements for [mypy,lint] in [dev]
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py23
1 files changed, 14 insertions, 9 deletions
diff --git a/setup.py b/setup.py

index f8b4487bc1..220084a49d 100755 --- a/setup.py +++ b/setup.py
@@ -103,15 +103,6 @@ CONDITIONAL_REQUIREMENTS["lint"] = [ "flake8", ] -CONDITIONAL_REQUIREMENTS["dev"] = CONDITIONAL_REQUIREMENTS["lint"] + [ - # The following are used by the release script - "click==7.1.2", - "redbaron==0.9.2", - "GitPython==3.1.14", - "commonmark==0.9.1", - "pygithub==1.55", -] - CONDITIONAL_REQUIREMENTS["mypy"] = [ "mypy==0.910", "mypy-zope==0.3.2", @@ -130,6 +121,20 @@ CONDITIONAL_REQUIREMENTS["mypy"] = [ # parameterized_class decorator was introduced in parameterized 0.7.0 CONDITIONAL_REQUIREMENTS["test"] = ["parameterized>=0.7.0"] +CONDITIONAL_REQUIREMENTS["dev"] = ( + CONDITIONAL_REQUIREMENTS["lint"] + + CONDITIONAL_REQUIREMENTS["mypy"] + + CONDITIONAL_REQUIREMENTS["test"] + + [ + # The following are used by the release script + "click==7.1.2", + "redbaron==0.9.2", + "GitPython==3.1.14", + "commonmark==0.9.1", + "pygithub==1.55", + ] +) + setup( name="matrix-synapse", version=version,