summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorPatrick Cloke <clokep@users.noreply.github.com>2020-10-21 06:45:01 -0400
committerGitHub <noreply@github.com>2020-10-21 06:45:01 -0400
commit654cc9470eef8a6371f8ab6c8b4eae467068e329 (patch)
tree526ad9d37f925dbe0b572a736ac81f3065c7d260 /setup.py
parentAdd type hints to profile and base handlers. (#8609) (diff)
downloadsynapse-654cc9470eef8a6371f8ab6c8b4eae467068e329.tar.xz
Pin mypy-zope for compatibility with mypy. (#8600)
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 494f50239f..2f4a3170d2 100755
--- a/setup.py
+++ b/setup.py
@@ -102,7 +102,7 @@ CONDITIONAL_REQUIREMENTS["lint"] = [
     "flake8",
 ]
 
-CONDITIONAL_REQUIREMENTS["mypy"] = ["mypy==0.790", "mypy-zope"]
+CONDITIONAL_REQUIREMENTS["mypy"] = ["mypy==0.790", "mypy-zope==0.2.8"]
 
 # Dependencies which are exclusively required by unit test code. This is
 # NOT a list of all modules that are necessary to run the unit tests.