summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorMark Haines <mjark@negativecurvature.net>2015-05-06 12:54:07 +0100
committerMark Haines <mjark@negativecurvature.net>2015-05-06 12:54:07 +0100
commit3c11c9c122ec73c495bd691ba8608ad6a406b332 (patch)
tree8c9b339ce336b8d1dd45a3ac899c1875612236aa /setup.py
parentMerge pull request #138 from matrix-org/erikj/SYN-371 (diff)
parentAcutally add scripts-dev/ (diff)
downloadsynapse-3c11c9c122ec73c495bd691ba8608ad6a406b332.tar.xz
Merge pull request #140 from matrix-org/erikj/scripts_refactor
Seperate scripts/ into scripts/ and scripts-dev/
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index ab24159be7..f9929591e7 100755
--- a/setup.py
+++ b/setup.py
@@ -14,6 +14,7 @@
 # See the License for the specific language governing permissions and
 # limitations under the License.
 
+import glob
 import os
 from setuptools import setup, find_packages
 
@@ -55,5 +56,5 @@ setup(
     include_package_data=True,
     zip_safe=False,
     long_description=long_description,
-    scripts=["synctl", "register_new_matrix_user"],
+    scripts=["synctl"] + glob.glob("scripts/*"),
 )