summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorJonathan de Jong <jonathan@automatia.nl>2021-03-16 19:19:27 +0100
committerGitHub <noreply@github.com>2021-03-16 14:19:27 -0400
commit27d2820c33d94cd99aea128b6ade76a7de838c3d (patch)
treec81628d58ab2daf1184f1654df34ed0d2be30cd2 /setup.py
parentAdd SSO attribute requirements for OIDC providers (#9609) (diff)
downloadsynapse-27d2820c33d94cd99aea128b6ade76a7de838c3d.tar.xz
Enable flake8-bugbear, but disable most checks. (#9499)
* Adds B00 to ignored checks.
* Fixes remaining issues.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index bbd9e7862a..b834e4e55b 100755
--- a/setup.py
+++ b/setup.py
@@ -99,6 +99,7 @@ CONDITIONAL_REQUIREMENTS["lint"] = [
     "isort==5.7.0",
     "black==20.8b1",
     "flake8-comprehensions",
+    "flake8-bugbear",
     "flake8",
 ]