summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorDavid Robertson <davidr@element.io>2021-10-08 14:49:41 +0100
committerGitHub <noreply@github.com>2021-10-08 14:49:41 +0100
commit797ee7812db28f6cf130d68e2d10911c826b0be5 (patch)
tree7dc5c31a4f18ebdcdcae21d9987f85bfd8892a45 /setup.py
parentFix overwriting profile when making room public (#11003) (diff)
downloadsynapse-797ee7812db28f6cf130d68e2d10911c826b0be5.tar.xz
Relax `ignore-missing-imports` for modules that have stubs now and update mypy (#11006)
Updating mypy past version 0.9 means that third-party stubs are no-longer distributed with typeshed. See http://mypy-lang.blogspot.com/2021/06/mypy-0900-released.html for details.
We therefore pull in stub packages in setup.py

Additionally, some modules that we were previously ignoring import failures for now have stubs. So let's use them.

The rest of this change consists of fixups to make the newer mypy + stubs pass CI.

Co-authored-by: Patrick Cloke <clokep@users.noreply.github.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py11
1 files changed, 10 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c478563510..f8b4487bc1 100755
--- a/setup.py
+++ b/setup.py
@@ -112,7 +112,16 @@ CONDITIONAL_REQUIREMENTS["dev"] = CONDITIONAL_REQUIREMENTS["lint"] + [
     "pygithub==1.55",
 ]
 
-CONDITIONAL_REQUIREMENTS["mypy"] = ["mypy==0.812", "mypy-zope==0.2.13"]
+CONDITIONAL_REQUIREMENTS["mypy"] = [
+    "mypy==0.910",
+    "mypy-zope==0.3.2",
+    "types-bleach>=4.1.0",
+    "types-jsonschema>=3.2.0",
+    "types-Pillow>=8.3.4",
+    "types-pyOpenSSL>=20.0.7",
+    "types-PyYAML>=5.4.10",
+    "types-setuptools>=57.4.0",
+]
 
 # Dependencies which are exclusively required by unit test code. This is
 # NOT a list of all modules that are necessary to run the unit tests.