summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorV02460 <V02460@gmail.com>2021-12-20 16:34:46 +0100
committerGitHub <noreply@github.com>2021-12-20 10:34:46 -0500
commit7a7ca8f2263f8750b8ff2c18b9aefaf4a3626235 (patch)
tree1cfb2b70b55e5b8497fd35efdebb956211d5949a /setup.py
parentAdd opentracing types (#11603) (diff)
downloadsynapse-7a7ca8f2263f8750b8ff2c18b9aefaf4a3626235.tar.xz
Use mock from standard library (#11588)
Instead of the backported version.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 1 insertions, 3 deletions
diff --git a/setup.py b/setup.py

index 812459074a..e113da6782 100755 --- a/setup.py +++ b/setup.py
@@ -120,9 +120,7 @@ CONDITIONAL_REQUIREMENTS["mypy"] = [ # Tests assume that all optional dependencies are installed. # # parameterized_class decorator was introduced in parameterized 0.7.0 -# -# We use `mock` library as that backports `AsyncMock` to Python 3.6 -CONDITIONAL_REQUIREMENTS["test"] = ["parameterized>=0.7.0", "mock>=4.0.0"] +CONDITIONAL_REQUIREMENTS["test"] = ["parameterized>=0.7.0"] CONDITIONAL_REQUIREMENTS["dev"] = ( CONDITIONAL_REQUIREMENTS["lint"]