summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorSean Quah <8349537+squahtx@users.noreply.github.com>2022-02-18 15:57:26 +0000
committerGitHub <noreply@github.com>2022-02-18 15:57:26 +0000
commite6acd3cf4fe6910e99683c2ebe3dd917f0a3ae14 (patch)
treea65f548f8ba5e67a20149d805770166e169a0397 /setup.py
parentFix bug in `StateFilter.return_expanded()` and add some tests. (#12016) (diff)
downloadsynapse-e6acd3cf4fe6910e99683c2ebe3dd917f0a3ae14.tar.xz
Upgrade mypy to version 0.931 (#12030)
Upgrade mypy to 0.931, mypy-zope to 0.3.5 and fix new complaints.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index d0511c767f..c80cb6f207 100755
--- a/setup.py
+++ b/setup.py
@@ -103,8 +103,8 @@ CONDITIONAL_REQUIREMENTS["lint"] = [
 ]
 
 CONDITIONAL_REQUIREMENTS["mypy"] = [
-    "mypy==0.910",
-    "mypy-zope==0.3.2",
+    "mypy==0.931",
+    "mypy-zope==0.3.5",
     "types-bleach>=4.1.0",
     "types-jsonschema>=3.2.0",
     "types-opentracing>=2.4.2",