summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorMark Haines <mark.haines@matrix.org>2015-08-26 13:13:01 +0100
committerMark Haines <mark.haines@matrix.org>2015-08-26 13:13:01 +0100
commit06094591c5397af64a495dce2271da2df5b491b9 (patch)
treec235e296128627372308fef510d18f7f970247ff /setup.py
parentInstall tox locally if it wasn't already installed when running setup.py test (diff)
downloadsynapse-06094591c5397af64a495dce2271da2df5b491b9.tar.xz
Pass an empty list of arguments to tox if no arguments are given
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 4a7b3c99aa..0e3f2f18d5 100755
--- a/setup.py
+++ b/setup.py
@@ -65,6 +65,8 @@ class Tox(Command):
         args = self.tox_args
         if args:
             args = shlex.split(self.tox_args)
+        else:
+            args = []
         errno = tox.cmdline(args=args)
         sys.exit(errno)