summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorErik Johnston <erik@matrix.org>2022-04-12 11:49:02 +0100
committerGitHub <noreply@github.com>2022-04-12 10:49:02 +0000
commit3ad74b63e5721d318981d22d3b5c948c72506342 (patch)
tree509704578ffd57cdd0c83a0aeee377dca0fea2d1 /setup.py
parentWorkaround pip bug installing latest treq and not-latest twisted from hashes ... (diff)
downloadsynapse-3ad74b63e5721d318981d22d3b5c948c72506342.tar.xz
Specify tls extra for Twisted dependency. (#12444)
* Specify `tls` extra for Twisted dependency.

It was already pulled in for us by `treq`, but we should be explicit
that we do use the `tls` functionality of Twisted directly.

* Mark `idna` as dev-dependency

This doesn't actually change anything, as `Twisted[tls]` will put it in
as a main dependency anyway.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 48bd418bb8..ecd30247ed 100755
--- a/setup.py
+++ b/setup.py
@@ -120,7 +120,7 @@ CONDITIONAL_REQUIREMENTS["mypy"] = [
 # Tests assume that all optional dependencies are installed.
 #
 # parameterized_class decorator was introduced in parameterized 0.7.0
-CONDITIONAL_REQUIREMENTS["test"] = ["parameterized>=0.7.0"]
+CONDITIONAL_REQUIREMENTS["test"] = ["parameterized>=0.7.0", "idna>=2.5"]
 
 CONDITIONAL_REQUIREMENTS["dev"] = (
     CONDITIONAL_REQUIREMENTS["lint"]