summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorWill Hunt <will@half-shot.uk>2020-09-28 11:11:57 +0100
committerGitHub <noreply@github.com>2020-09-28 11:11:57 +0100
commit6201ea56eeae22258d58db2f7381f96759f5e85e (patch)
tree37cb630a46fe96e416110de253ad50d256c0482e /setup.py
parentAdd support for device messages, start support for device lists (diff)
parenttypo (diff)
downloadsynapse-6201ea56eeae22258d58db2f7381f96759f5e85e.tar.xz
Merge branch 'develop' into hs/super-wip-edus-down-sync
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py16
1 files changed, 16 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 54ddec8f9f..926b1bc86f 100755
--- a/setup.py
+++ b/setup.py
@@ -94,6 +94,22 @@ ALL_OPTIONAL_REQUIREMENTS = dependencies["ALL_OPTIONAL_REQUIREMENTS"]
 # Make `pip install matrix-synapse[all]` install all the optional dependencies.
 CONDITIONAL_REQUIREMENTS["all"] = list(ALL_OPTIONAL_REQUIREMENTS)
 
+# Developer dependencies should not get included in "all".
+#
+# We pin black so that our tests don't start failing on new releases.
+CONDITIONAL_REQUIREMENTS["lint"] = [
+    "isort==5.0.3",
+    "black==19.10b0",
+    "flake8-comprehensions",
+    "flake8",
+]
+
+# Dependencies which are exclusively required by unit test code. This is
+# NOT a list of all modules that are necessary to run the unit tests.
+# Tests assume that all optional dependencies are installed.
+#
+# parameterized_class decorator was introduced in parameterized 0.7.0
+CONDITIONAL_REQUIREMENTS["test"] = ["mock>=2.0", "parameterized>=0.7.0"]
 
 setup(
     name="matrix-synapse",