summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorShay <hillerys@element.io>2021-12-23 20:22:15 -0800
committerGitHub <noreply@github.com>2021-12-23 20:22:15 -0800
commitfcfe67578f70bb4f150b83cfad708f5bc0474c1e (patch)
treed261c90da64b3788b05d54e7fcec873c467effcd /setup.py
parentFix mypy error with opentracing.tags. (#11622) (diff)
downloadsynapse-fcfe67578f70bb4f150b83cfad708f5bc0474c1e.tar.xz
Update to the current version of Black and run it on Synapse codebase (#11596)
* update black version

* run updated version of black on code

* newsfragment

* enumerate python versions
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index e113da6782..fbb0133016 100755
--- a/setup.py
+++ b/setup.py
@@ -96,7 +96,7 @@ CONDITIONAL_REQUIREMENTS["all"] = list(ALL_OPTIONAL_REQUIREMENTS)
 # We pin black so that our tests don't start failing on new releases.
 CONDITIONAL_REQUIREMENTS["lint"] = [
     "isort==5.7.0",
-    "black==21.6b0",
+    "black==21.12b0",
     "flake8-comprehensions",
     "flake8-bugbear==21.3.2",
     "flake8",