summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorErik Johnston <erik@matrix.org>2021-11-03 11:10:25 +0000
committerGitHub <noreply@github.com>2021-11-03 11:10:25 +0000
commitbcc115c28d857fa54919bbe564f37e97f7a8ac81 (patch)
treef0d7fbf58c97c76e0f08ce0a41dfb7ebef1f4b00 /setup.py
parentfix a small typo in the delete room api docs (diff)
downloadsynapse-bcc115c28d857fa54919bbe564f37e97f7a8ac81.tar.xz
Add twine and towncrier as dev dependencies (#11233)
We don't pin them as we execute them as commands, rather than use them
as libs.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 220084a49d..345cff09c3 100755
--- a/setup.py
+++ b/setup.py
@@ -132,6 +132,9 @@ CONDITIONAL_REQUIREMENTS["dev"] = (
         "GitPython==3.1.14",
         "commonmark==0.9.1",
         "pygithub==1.55",
+        # The following are executed as commands by the release script.
+        "twine",
+        "towncrier",
     ]
 )