summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorDan Callahan <danc@element.io>2021-11-09 16:22:47 +0000
committerGitHub <noreply@github.com>2021-11-09 16:22:47 +0000
commit3b951445a7499ecfc2d8d63fe1bb198b422c25cc (patch)
tree3df93c6f147c19bc1e8a17c0f7f9510942f4b62a /setup.py
parentClarifications and small fixes to to-device related code (#11247) (diff)
downloadsynapse-3b951445a7499ecfc2d8d63fe1bb198b422c25cc.tar.xz
Require mypy for synapse/ & tests/ unless excluded (#11282)
Signed-off-by: Dan Callahan <danc@element.io>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 2 insertions, 3 deletions
diff --git a/setup.py b/setup.py

index 345cff09c3..5d602db240 100755 --- a/setup.py +++ b/setup.py
@@ -17,6 +17,7 @@ # limitations under the License. import glob import os +from typing import Any, Dict from setuptools import Command, find_packages, setup @@ -49,8 +50,6 @@ here = os.path.abspath(os.path.dirname(__file__)) # [1]: http://tox.readthedocs.io/en/2.5.0/example/basic.html#integration-with-setup-py-test-command # [2]: https://pypi.python.org/pypi/setuptools_trial class TestCommand(Command): - user_options = [] - def initialize_options(self): pass @@ -75,7 +74,7 @@ def read_file(path_segments): def exec_file(path_segments): """Execute a single python file to get the variables defined in it""" - result = {} + result: Dict[str, Any] = {} code = read_file(path_segments) exec(code, result) return result