summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorMark Haines <mark.haines@matrix.org>2015-02-02 13:17:45 +0000
committerMark Haines <mark.haines@matrix.org>2015-02-02 13:17:45 +0000
commitd3dd7490447bc3bd067ea34af8a69f157374c980 (patch)
tree759f5dfb188805d2541face6766adc98cdef823c /setup.py
parentTell people to "source" the activate script for virtualenv, Remove --user fro... (diff)
downloadsynapse-d3dd7490447bc3bd067ea34af8a69f157374c980.tar.xz
Pin the version of Twisted to 14.0.2 since we are using some of its internals
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index f0e9e7d264..bde26c0b97 100755
--- a/setup.py
+++ b/setup.py
@@ -33,7 +33,7 @@ setup(
     install_requires=[
         "syutil==0.0.2",
         "matrix_angular_sdk>=0.6.1",
-        "Twisted>=14.0.0",
+        "Twisted==14.0.2",
         "service_identity>=1.0.0",
         "pyopenssl>=0.14",
         "pyyaml",
@@ -50,6 +50,7 @@ setup(
         "https://github.com/matrix-org/matrix-angular-sdk/tarball/v0.6.1/#egg=matrix_angular_sdk-0.6.1",
     ],
     setup_requires=[
+        "Twisted==14.0.2",
         "setuptools_trial",
         "setuptools>=1.0.0", # Needs setuptools that supports git+ssh.
                              # TODO: Do we need this now? we don't use git+ssh.