summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorAmber Brown <hawkowl@atleastfornow.net>2019-06-12 21:31:59 +1000
committerGitHub <noreply@github.com>2019-06-12 21:31:59 +1000
commit09e9a26b7181e36af7e2a4a0795d68f962742738 (patch)
treeaaf5fb054d5f004a0bb67dd780f89dd2e5a2930f /setup.py
parentMerge branch 'master' of github.com:matrix-org/synapse into develop (diff)
downloadsynapse-09e9a26b7181e36af7e2a4a0795d68f962742738.tar.xz
Remove Python 2.7 support. (#5425)
* remove 2.7 from CI and publishing

* fill out classifiers and also make it not be installed on 3.5

* some minor bumps so that the old deps work on python 3.5
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py10
1 files changed, 10 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 55663e9cac..3492cdc5a0 100755
--- a/setup.py
+++ b/setup.py
@@ -102,6 +102,16 @@ setup(
     include_package_data=True,
     zip_safe=False,
     long_description=long_description,
+    python_requires='~=3.5',
+    classifiers=[
+        'Development Status :: 5 - Production/Stable',
+        'Topic :: Communications :: Chat',
+        'License :: OSI Approved :: Apache Software License',
+        'Programming Language :: Python :: 3 :: Only',
+        'Programming Language :: Python :: 3.5',
+        'Programming Language :: Python :: 3.6',
+        'Programming Language :: Python :: 3.7',
+    ],
     scripts=["synctl"] + glob.glob("scripts/*"),
     cmdclass={'test': TestCommand},
 )