summary refs log tree commit diff
path: root/rust/Cargo.toml
diff options
context:
space:
mode:
authorErik Johnston <erik@matrix.org>2022-09-29 16:12:09 +0100
committerGitHub <noreply@github.com>2022-09-29 16:12:09 +0100
commitebd9e2dac6495a1857617d1a76c9259a988f8bb4 (patch)
tree4c631115b311c76aa01c0894787b9e5a47062433 /rust/Cargo.toml
parentOptimise get_rooms_for_user (drop with_stream_ordering) (#13787) (diff)
downloadsynapse-ebd9e2dac6495a1857617d1a76c9259a988f8bb4.tar.xz
Implement push rule evaluation in Rust. (#13838)
Diffstat (limited to 'rust/Cargo.toml')
-rw-r--r--rust/Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/rust/Cargo.toml b/rust/Cargo.toml
index 44263bf77e..cffaa5b51b 100644
--- a/rust/Cargo.toml
+++ b/rust/Cargo.toml
@@ -11,7 +11,9 @@ rust-version = "1.58.1"
 
 [lib]
 name = "synapse"
-crate-type = ["cdylib"]
+# We generate a `cdylib` for Python and a standard `lib` for running
+# tests/benchmarks.
+crate-type = ["lib", "cdylib"]
 
 [package.metadata.maturin]
 # This is where we tell maturin where to place the built library.