summary refs log tree commit diff
path: root/rust/Cargo.toml
diff options
context:
space:
mode:
authorErik Johnston <erik@matrix.org>2022-09-12 11:03:42 +0100
committerGitHub <noreply@github.com>2022-09-12 10:03:42 +0000
commitebfeac7c5ded851a2639911ec6adf9d0fcdb029a (patch)
tree972049d45c5fed1241ee4820705033cbba784d5f /rust/Cargo.toml
parentConcurrently collect room unread counts for push badges (#13765) (diff)
downloadsynapse-ebfeac7c5ded851a2639911ec6adf9d0fcdb029a.tar.xz
Check if Rust lib needs rebuilding. (#13759)
This protects against the common mistake of failing to remember to rebuild Rust code after making changes.
Diffstat (limited to 'rust/Cargo.toml')
-rw-r--r--rust/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/rust/Cargo.toml b/rust/Cargo.toml
index 0a9760cafc..deddf3cec2 100644
--- a/rust/Cargo.toml
+++ b/rust/Cargo.toml
@@ -19,3 +19,7 @@ name = "synapse.synapse_rust"
 
 [dependencies]
 pyo3 = { version = "0.16.5", features = ["extension-module", "macros", "abi3", "abi3-py37"] }
+
+[build-dependencies]
+blake2 = "0.10.4"
+hex = "0.4.3"