summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDavid Robertson <davidr@element.io>2022-10-12 10:47:02 +0100
committerGitHub <noreply@github.com>2022-10-12 10:47:02 +0100
commit3f057e4c54ff1e4ef8b4f651c35d4698b389fe9b (patch)
treea70e7d5a9a7b49ccc25edd6b1066ee30d4636b03 /pyproject.toml
parentFix a bug where redactions were not being sent over federation if we did not ... (diff)
downloadsynapse-3f057e4c54ff1e4ef8b4f651c35d4698b389fe9b.tar.xz
Use minimal Rust installation in docker images and CI (#14141)
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 5e36baf40d..3dc4b66ca9 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -316,7 +316,7 @@ build-backend = "poetry.core.masonry.api"
 skip = "cp36* *-musllinux_i686"
 
 # We need a rust compiler
-before-all =  "curl https://sh.rustup.rs -sSf | sh -s -- --default-toolchain stable -y"
+before-all =  "curl https://sh.rustup.rs -sSf | sh -s -- --default-toolchain stable -y --profile minimal"
 environment= { PATH = "$PATH:$HOME/.cargo/bin" }
 
 # For some reason if we don't manually clean the build directory we