summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorErik Johnston <erik@matrix.org>2022-10-21 15:17:19 +0100
committerGitHub <noreply@github.com>2022-10-21 14:17:19 +0000
commit5f77b74215b1f1549d776f7ca7a27b907d51a08e (patch)
tree4c21ac8ce43e3498a884d502c2fa5865c339d4e9 /pyproject.toml
parentProperly update the threads table when thread events are redacted. (#14248) (diff)
downloadsynapse-5f77b74215b1f1549d776f7ca7a27b907d51a08e.tar.xz
Try building ABI3 wheels for cpython (#14253)
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml9
1 files changed, 9 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 6ebac41ed1..78011be490 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -330,3 +330,12 @@ environment= { PATH = "$PATH:$HOME/.cargo/bin" }
 before-build = "rm -rf {project}/build"
 build-frontend = "build"
 test-command = "python -c 'from synapse.synapse_rust import sum_as_string; print(sum_as_string(1, 2))'"
+
+
+[tool.cibuildwheel.linux]
+# Wrap the repair command to correctly rename the built cpython wheels as ABI3.
+repair-wheel-command = "./.ci/scripts/auditwheel_wrapper.py -w {dest_dir} {wheel}"
+
+[tool.cibuildwheel.macos]
+# Wrap the repair command to correctly rename the built cpython wheels as ABI3.
+repair-wheel-command = "./.ci/scripts/auditwheel_wrapper.py --require-archs {delocate_archs} -w {dest_dir} {wheel}"