summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorPatrick Cloke <clokep@users.noreply.github.com>2023-08-29 08:34:53 -0400
committerGitHub <noreply@github.com>2023-08-29 08:34:53 -0400
commit2d72367367ab39fb1762d2fac28990f00b1bdb52 (patch)
tree9ec52fcf078abf2bec6cbc4154eb2ca1d439c89e /pyproject.toml
parentFix inaccurate error message while trying to ban or unban a user with the sam... (diff)
downloadsynapse-2d72367367ab39fb1762d2fac28990f00b1bdb52.tar.xz
Update black & fix the targeted Python versions. (#16187)
Black should target Python 3.8 to 3.11.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml9
1 files changed, 6 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index c2421d7257..499dd9532d 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -35,7 +35,7 @@
         showcontent = true
 
 [tool.black]
-target-version = ['py37', 'py38', 'py39', 'py310']
+target-version = ['py38', 'py39', 'py310', 'py311']
 # black ignores everything in .gitignore by default, see
 # https://black.readthedocs.io/en/stable/usage_and_configuration/file_collection_and_discovery.html#gitignore
 # Use `extend-exclude` if you want to exclude something in addition to this.
@@ -306,9 +306,12 @@ all = [
 ]
 
 [tool.poetry.dev-dependencies]
-# We pin black so that our tests don't start failing on new releases.
+# We pin development dependencies in poetry.lock so that our tests don't start
+# failing on new releases. Keeping lower bounds loose here means that dependabot
+# can bump versions without having to update the content-hash in the lockfile.
+# This helps prevents merge conflicts when running a batch of dependabot updates.
 isort = ">=5.10.1"
-black = ">=22.3.0"
+black = ">=22.7.0"
 ruff = "0.0.277"
 
 # Typechecking