summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorAmber H. Brown <hawkowl@atleastfornow.net>2019-07-02 18:31:29 +1000
committerAmber H. Brown <hawkowl@atleastfornow.net>2019-07-02 18:31:29 +1000
commit4689408a35e6ff9b7b18a5940e79d15e6b846913 (patch)
tree4bf2c4347abb712bf7cad0040809409cc8cd6c72 /pyproject.toml
parentrelease shhs on tags (diff)
parentfix async/await consentresource (#5585) (diff)
downloadsynapse-4689408a35e6ff9b7b18a5940e79d15e6b846913.tar.xz
Merge remote-tracking branch 'origin/develop' into shhs
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index dd099dc9c8..ec23258da8 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -28,3 +28,22 @@
         directory = "misc"
         name = "Internal Changes"
         showcontent = true
+
+[tool.black]
+target-version = ['py34']
+exclude = '''
+
+(
+  /(
+      \.eggs         # exclude a few common directories in the
+    | \.git          # root of the project
+    | \.tox
+    | \.venv
+    | _build
+    | _trial_temp.*
+    | build
+    | dist
+    | debian
+  )/
+)
+'''