summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDavid Robertson <davidr@element.io>2022-06-17 19:07:04 +0100
committerGitHub <noreply@github.com>2022-06-17 19:07:04 +0100
commitf33356e8f86f5271376467febfad0936e4e8a72d (patch)
tree76448f2c67797e2d0dd59801eeb4181d1daa3a74 /pyproject.toml
parentUpdate opentracing docs to reference the configuration manual rather than the... (diff)
downloadsynapse-f33356e8f86f5271376467febfad0936e4e8a72d.tar.xz
Use caret (semver bounds) for matrix.org packages (#13082)
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 44aa775c33..3a56c42c0b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -110,9 +110,9 @@ jsonschema = ">=3.0.0"
 frozendict = ">=1,!=2.1.2"
 # We require 2.1.0 or higher for type hints. Previous guard was >= 1.1.0
 unpaddedbase64 = ">=2.1.0"
-canonicaljson = ">=1.4.0"
+canonicaljson = "^1.4.0"
 # we use the type definitions added in signedjson 1.1.
-signedjson = ">=1.1.0"
+signedjson = "^1.1.0"
 # validating SSL certs for IP addresses requires service_identity 18.1.
 service-identity = ">=18.1.0"
 # Twisted 18.9 introduces some logger improvements that the structured
@@ -150,7 +150,7 @@ typing-extensions = ">=3.10.0.1"
 cryptography = ">=3.4.7"
 # ijson 3.1.4 fixes a bug with "." in property names
 ijson = ">=3.1.4"
-matrix-common = "~=1.2.1"
+matrix-common = "^1.2.1"
 # We need packaging.requirements.Requirement, added in 16.1.
 packaging = ">=16.1"
 # At the time of writing, we only use functions from the version `importlib.metadata`