summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDavid Robertson <davidr@element.io>2022-04-05 19:25:56 +0100
committerGitHub <noreply@github.com>2022-04-05 18:25:56 +0000
commit573cd0f92f78de54cbe5dc9d0bf9f904f9d90011 (patch)
tree7faeff28e857684b768442228592418ff039f1af /pyproject.toml
parentPoetry: initial pyproject.toml and poetry.lock (#12381) (diff)
downloadsynapse-573cd0f92f78de54cbe5dc9d0bf9f904f9d90011.tar.xz
Add missing dependency on importlib_metadata (#12384)
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 19ffdc7b2c..92ea302b75 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -167,6 +167,9 @@ ijson = ">=3.1.4"
 matrix-common = "~=1.1.0"
 # We need packaging.requirements.Requirement, added in 16.1.
 packaging = ">=16.1"
+# At the time of writing, we only use functions from the version `importlib.metadata`
+# which shipped in Python 3.8. This corresponds to version 1.4 of the backport.
+importlib_metadata = { version = ">=1.4", python = "<3.8" }
 
 
 # Optional Dependencies