summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMo Balaa <thebalaa@users.noreply.github.com>2023-11-29 14:46:43 -0600
committerGitHub <noreply@github.com>2023-11-29 15:46:43 -0500
commit3a092699e569ebec37b0624be8164238cef949a5 (patch)
treeab460dc300380fb999d270be6d3d181121723543 /pyproject.toml
parentDeclare support for Matrix v1.7, v1.8, and v1.9. (#16707) (diff)
downloadsynapse-3a092699e569ebec37b0624be8164238cef949a5.tar.xz
Upgrade poetry-core range to fix issue with .so file (#16702)
poetry-core 1.8.x includes a fix which properly moves the generate
synapse_rust.abi3.so file to the synapse directory when using an
editable install.

Without this change developers are left with a confusing experience
of the synapse.synapse_rust module not being found after installation.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index b2a4fd7a2f..b0ccf82e10 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -382,7 +382,7 @@ furo = ">=2022.12.7,<2024.0.0"
 # runtime errors caused by build system changes.
 # We are happy to raise these upper bounds upon request,
 # provided we check that it's safe to do so (i.e. that CI passes).
-requires = ["poetry-core>=1.1.0,<=1.7.0", "setuptools_rust>=1.3,<=1.8.1"]
+requires = ["poetry-core>=1.1.0,<=1.8.1", "setuptools_rust>=1.3,<=1.8.1"]
 build-backend = "poetry.core.masonry.api"