summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorreivilibre <oliverw@matrix.org>2023-03-24 16:41:10 +0000
committerGitHub <noreply@github.com>2023-03-24 16:41:10 +0000
commitd5324ee111ea56fa466eab7e3974dc4894a64d46 (patch)
treeff7b2523083d585eea3e8f4548c96634f4fb0192 /pyproject.toml
parentAs an optimisation, use `TRUNCATE` on Postgres when clearing the user directo... (diff)
downloadsynapse-d5324ee111ea56fa466eab7e3974dc4894a64d46.tar.xz
Add developer documentation for the Federation Sender and add a documentation mechanism using Sphinx. (#15265)
Co-authored-by: Patrick Cloke <clokep@users.noreply.github.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml12
1 files changed, 12 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index c0111dd796..d10c390043 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -350,6 +350,18 @@ towncrier = ">=18.6.0rc1"
 # Used for checking the Poetry lockfile
 tomli = ">=1.2.3"
 
+
+# Dependencies for building the development documentation
+[tool.poetry.group.dev-docs]
+optional = true
+
+[tool.poetry.group.dev-docs.dependencies]
+sphinx = {version = "^6.1", python = "^3.8"}
+sphinx-autodoc2 = {version = "^0.4.2", python = "^3.8"}
+myst-parser = {version = "^1.0.0", python = "^3.8"}
+furo = "^2022.12.7"
+
+
 [build-system]
 # The upper bounds here are defensive, intended to prevent situations like
 # #13849 and #14079 where we see buildtime or runtime errors caused by build