summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorAmber Brown <hawkowl@atleastfornow.net>2018-07-19 21:25:47 +1000
committerAmber Brown <hawkowl@atleastfornow.net>2018-07-19 21:25:47 +1000
commit37af0d2a13f2d17e6de9e7d1201118cb633d7c55 (patch)
tree4707103e1b83e0ef4067a4894ff932c3bf183ded /pyproject.toml
parentrst -> md (diff)
downloadsynapse-37af0d2a13f2d17e6de9e7d1201118cb633d7c55.tar.xz
make pyproject point at it
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml29
1 files changed, 27 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index d1603b5d8b..1453ddd530 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,5 +1,30 @@
 [tool.towncrier]
     package = "synapse"
-    filename = "CHANGES.rst"
+    filename = "CHANGES.md"
     directory = "changelog.d"
-    issue_format = "`#{issue} <https://github.com/matrix-org/synapse/issues/{issue}>`_"
+    issue_format = "[\#{issue}](https://github.com/matrix-org/synapse/issues/{issue}>)"
+
+    [[tool.towncrier.type]]
+        directory = "feature"
+        name = "Features"
+        showcontent = true
+
+    [[tool.towncrier.type]]
+        directory = "bugfix"
+        name = "Bugfixes"
+        showcontent = true
+
+    [[tool.towncrier.type]]
+        directory = "doc"
+        name = "Improved Documentation"
+        showcontent = true
+
+    [[tool.towncrier.type]]
+        directory = "removal"
+        name = "Deprecations and Removals"
+        showcontent = true
+
+    [[tool.towncrier.type]]
+        directory = "misc"
+        name = "Internal Changes"
+        showcontent = true