summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDavid Robertson <davidr@element.io>2022-02-22 11:30:19 +0000
committerGitHub <noreply@github.com>2022-02-22 11:30:19 +0000
commit1ae492c8c09edef4a6d2af65588895305eaedec3 (patch)
tree1afe543f1b8fdcb12e2478401f62d694bc4240d1 /pyproject.toml
parentUse v3 endpoints for fallback auth (Matrix 1.1) (#12019) (diff)
downloadsynapse-1ae492c8c09edef4a6d2af65588895305eaedec3.tar.xz
Move isort config to `pyproject.toml` (#12052)
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml12
1 files changed, 12 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 963f149c6a..c9cd0cf6ec 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -54,3 +54,15 @@ exclude = '''
   )/
 )
 '''
+
+[tool.isort]
+line_length = 88
+sections = ["FUTURE", "STDLIB", "THIRDPARTY", "TWISTED", "FIRSTPARTY", "TESTS", "LOCALFOLDER"]
+default_section = "THIRDPARTY"
+known_first_party = ["synapse"]
+known_tests = ["tests"]
+known_twisted = ["twisted", "OpenSSL"]
+multi_line_output = 3
+include_trailing_comma = true
+combine_as_imports = true
+