summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorErik Johnston <erikj@element.io>2024-05-30 14:03:49 +0100
committerGitHub <noreply@github.com>2024-05-30 14:03:49 +0100
commit5624c8b961ed6a8310a2c6723ae13e854721756b (patch)
treee45dfc271ed2ec540170de66ccc3534b98de1992 /pyproject.toml
parentFix deduplicating of membership events to not create unused state groups. (#1... (diff)
downloadsynapse-5624c8b961ed6a8310a2c6723ae13e854721756b.tar.xz
In sync wait for worker to catch up since token (#17215)
Otherwise things will get confused.

An alternative would be to make sure that for lagging stream we don't
return anything (and make sure the returned next_batch token doesn't go
backwards). But that is a faff.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml6
1 files changed, 2 insertions, 4 deletions
diff --git a/pyproject.toml b/pyproject.toml
index ea14b98199..9a3348be49 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -200,10 +200,8 @@ netaddr = ">=0.7.18"
 # add a lower bound to the Jinja2 dependency.
 Jinja2 = ">=3.0"
 bleach = ">=1.4.3"
-# We use `ParamSpec` and `Concatenate`, which were added in `typing-extensions` 3.10.0.0.
-# Additionally we need https://github.com/python/typing/pull/817 to allow types to be
-# generic over ParamSpecs.
-typing-extensions = ">=3.10.0.1"
+# We use `Self`, which were added in `typing-extensions` 4.0.
+typing-extensions = ">=4.0"
 # We enforce that we have a `cryptography` version that bundles an `openssl`
 # with the latest security patches.
 cryptography = ">=3.4.7"