summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDavid Robertson <davidr@element.io>2023-07-11 15:16:19 +0100
committerGitHub <noreply@github.com>2023-07-11 15:16:19 +0100
commit92014fbf7286afa9099d162b22feda868af820f8 (patch)
tree837573f62de16394fe9411d7ab891073795c3ebc /pyproject.toml
parentCall out upgrade notes in README (diff)
downloadsynapse-92014fbf7286afa9099d162b22feda868af820f8.tar.xz
Don't build wheels for Python 3.7 (#15917) v1.88.0rc1
* Don't build wheels for CPython or PyPy 3.7

* Update pyproject.toml comments

* Manually update the changelog
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml10
1 files changed, 9 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index b61b8b17ac..d56602b2df 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -373,7 +373,15 @@ build-backend = "poetry.core.masonry.api"
 
 [tool.cibuildwheel]
 # Skip unsupported platforms (by us or by Rust).
-skip = "cp36* *-musllinux_i686 pp*aarch64 *-musllinux_aarch64"
+# See https://cibuildwheel.readthedocs.io/en/stable/options/#build-skip for the list of build targets.
+# We skip:
+#  - CPython 3.6 and 3.7: EOLed
+#  - PyPy 3.7: we only support Python 3.8+
+#  - musllinux i686: excluded to reduce number of wheels we build.
+#    c.f. https://github.com/matrix-org/synapse/pull/12595#discussion_r963107677
+#  - PyPy on Aarch64 and musllinux on aarch64: too slow to build.
+#    c.f. https://github.com/matrix-org/synapse/pull/14259
+skip = "cp36* cp37* pp37* *-musllinux_i686 pp*aarch64 *-musllinux_aarch64"
 
 # We need a rust compiler
 before-all =  "curl https://sh.rustup.rs -sSf | sh -s -- --default-toolchain stable -y --profile minimal"