summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorEric Eastwood <erice@element.io>2023-07-05 18:45:42 -0500
committerGitHub <noreply@github.com>2023-07-05 18:45:42 -0500
commit561d06b481176f61ed12f5a4723b127ff8624662 (patch)
treedd8698aac20317b551250e90c28dd5dc5c3e8042 /pyproject.toml
parentAdd basic read/write lock (#15782) (diff)
downloadsynapse-561d06b481176f61ed12f5a4723b127ff8624662.tar.xz
Remove support for Python 3.7 (#15851)
Fix https://github.com/matrix-org/synapse/issues/15836
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml5
1 files changed, 1 insertions, 4 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 192a07756b..a6e3a935a9 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -147,7 +147,7 @@ synapse_review_recent_signups = "synapse._scripts.review_recent_signups:main"
 update_synapse_database = "synapse._scripts.update_synapse_database:main"
 
 [tool.poetry.dependencies]
-python = "^3.7.1"
+python = "^3.8.0"
 
 # Mandatory Dependencies
 # ----------------------
@@ -203,9 +203,6 @@ ijson = ">=3.1.4"
 matrix-common = "^1.3.0"
 # We need packaging.requirements.Requirement, added in 16.1.
 packaging = ">=16.1"
-# At the time of writing, we only use functions from the version `importlib.metadata`
-# which shipped in Python 3.8. This corresponds to version 1.4 of the backport.
-importlib_metadata = { version = ">=1.4", python = "<3.8" }
 # This is the most recent version of Pydantic with available on common distros.
 # We are currently incompatible with >=2.0.0: (https://github.com/matrix-org/synapse/issues/15858)
 pydantic = "^1.7.4"