summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorPaarth Shah <mail@shahpaarth.com>2023-07-04 00:33:24 -0700
committerGitHub <noreply@github.com>2023-07-04 09:33:24 +0200
commit670d590f8a167d909f8d76a5ecbd240d9609d2b0 (patch)
treea0117a0445d35753e36b72a7109c2f2f19f9abcf /pyproject.toml
parentdevices: use combined ANY clause for faster cleanup (#15861) (diff)
downloadsynapse-670d590f8a167d909f8d76a5ecbd240d9609d2b0.tar.xz
Pin `pydantic` to <2.0.0 (#15862)
Signed-off-by: Paarth Shah <mail@shahpaarth.com>
Diffstat (limited to '')
-rw-r--r--pyproject.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index fc47b1ef71..67ee3f1738 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -207,7 +207,8 @@ packaging = ">=16.1"
 # which shipped in Python 3.8. This corresponds to version 1.4 of the backport.
 importlib_metadata = { version = ">=1.4", python = "<3.8" }
 # This is the most recent version of Pydantic with available on common distros.
-pydantic = ">=1.7.4"
+# We are currently incompatible with >=2.0.0: (https://github.com/matrix-org/synapse/issues/15858)
+pydantic = "^1.7.4"
 
 # This is for building the rust components during "poetry install", which
 # currently ignores the `build-system.requires` directive (c.f.