summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDavid Robertson <davidr@element.io>2022-10-18 16:44:43 +0100
committerGitHub <noreply@github.com>2022-10-18 16:44:43 +0100
commit844ce47b9bf62b4bb84df138c5d1b0be4ea08420 (patch)
tree80672d693d938ff1afef3b8aadbd649849974268 /pyproject.toml
parentFixes to release-artifacts warnings (#14224) (diff)
downloadsynapse-844ce47b9bf62b4bb84df138c5d1b0be4ea08420.tar.xz
Don't pin dev-deps in pyproject; use lower bounds (#14227)
* Don't pin dev-deps in pyproject; use lower bounds

This makes it slightly less tedious to update these things via
successive dependabot updates, by reducing the likelihood of a merge
conflict.

* Changelog

* Changelog
Diffstat (limited to '')
-rw-r--r--pyproject.toml12
1 files changed, 6 insertions, 6 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 8bc24c556a..554eed0fa4 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -267,10 +267,10 @@ all = [
 
 [tool.poetry.dev-dependencies]
 ## We pin black so that our tests don't start failing on new releases.
-isort = "==5.10.1"
-black = "==22.3.0"
+isort = ">=5.10.1"
+black = ">=22.3.0"
 flake8-comprehensions = "*"
-flake8-bugbear = "==21.3.2"
+flake8-bugbear = ">=21.3.2"
 flake8 = "*"
 
 # Typechecking
@@ -296,11 +296,11 @@ parameterized = ">=0.7.4"
 idna = ">=2.5"
 
 # The following are used by the release script
-click = "==8.1.3"
+click = ">=8.1.3"
 # GitPython was == 3.1.14; bumped to 3.1.20, the first release with type hints.
 GitPython = ">=3.1.20"
-commonmark = "==0.9.1"
-pygithub = "==1.55"
+commonmark = ">=0.9.1"
+pygithub = ">=1.55"
 # The following are executed as commands by the release script.
 twine = "*"
 # Towncrier min version comes from #3425. Rationale unclear.