summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorBrendan Abolivier <babolivier@matrix.org>2022-07-18 17:30:59 +0200
committerGitHub <noreply@github.com>2022-07-18 17:30:59 +0200
commit8c60c572f011a502040b509ae648fd5cad3d4428 (patch)
treebe3a6ae9cbd3f060f23e353a0312535a98a89fc8 /pyproject.toml
parentPrevent #3679 from appearing in blame results (#13311) (diff)
downloadsynapse-8c60c572f011a502040b509ae648fd5cad3d4428.tar.xz
Up the dependency on canonicaljson to ^1.5.0 (#13172)
Co-authored-by: David Robertson <davidr@element.io>
Diffstat (limited to '')
-rw-r--r--pyproject.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index f77c02ca27..21bea2ba01 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -110,7 +110,9 @@ jsonschema = ">=3.0.0"
 frozendict = ">=1,!=2.1.2"
 # We require 2.1.0 or higher for type hints. Previous guard was >= 1.1.0
 unpaddedbase64 = ">=2.1.0"
-canonicaljson = "^1.4.0"
+# We require 1.5.0 to work around an issue when running against the C implementation of
+# frozendict: https://github.com/matrix-org/python-canonicaljson/issues/36
+canonicaljson = "^1.5.0"
 # we use the type definitions added in signedjson 1.1.
 signedjson = "^1.1.0"
 # validating SSL certs for IP addresses requires service_identity 18.1.