summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
authoricp <pangolin@vivaldi.net>2023-02-07 01:04:14 +0530
committerGitHub <noreply@github.com>2023-02-06 19:34:14 +0000
commit64a631879c8be583efe47ca48e39f6cdf6115645 (patch)
tree93956a19e7a26ccad5b94713c53ebf8f59668690 /pyproject.toml
parentAdd missing types to test_state. (#14985) (diff)
downloadsynapse-64a631879c8be583efe47ca48e39f6cdf6115645.tar.xz
Allow poetry-core 1.5.0 (#14949)
Diffstat (limited to '')
-rw-r--r--pyproject.toml6
1 files changed, 4 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 8f7ced99a2..12734dec71 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -127,7 +127,9 @@ exclude = [
     { path = "synapse/*.so", format = "sdist"}
 ]
 
-build = "build_rust.py"
+[tool.poetry.build]
+script = "build_rust.py"
+generate-setup-file = true
 
 [tool.poetry.scripts]
 synapse_homeserver = "synapse.app.homeserver:main"
@@ -350,7 +352,7 @@ towncrier = ">=18.6.0rc1"
 # system changes.
 # We are happy to raise these upper bounds upon request,
 # provided we check that it's safe to do so (i.e. that CI passes).
-requires = ["poetry-core>=1.0.0,<=1.3.2", "setuptools_rust>=1.3,<=1.5.2"]
+requires = ["poetry-core>=1.0.0,<=1.5.0", "setuptools_rust>=1.3,<=1.5.2"]
 build-backend = "poetry.core.masonry.api"