summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorreivilibre <oliverw@matrix.org>2023-07-03 10:39:52 +0000
committerGitHub <noreply@github.com>2023-07-03 11:39:52 +0100
commitcd8b73aa97cb6d06079f67aa73ff24679038d7c6 (patch)
tree1dd87f71e51ea2ac65cf18e3dc013ede762a844c /flake.nix
parentAdd a timeout that aborts any Postgres statement taking more than 1 hour. (#1... (diff)
downloadsynapse-cd8b73aa97cb6d06079f67aa73ff24679038d7c6.tar.xz
Fix the `devenv up` configuration which was ignoring the config overrides. (#15854)
* Fix use of config override directory in `devenv up`

`--config-directory` is for the generate config script; `-c` is for usage

* Add homeserver config override directory to gitignore

* Newsfile

Signed-off-by: Olivier Wilkinson (reivilibre) <oliverw@matrix.org>

---------

Signed-off-by: Olivier Wilkinson (reivilibre) <oliverw@matrix.org>
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 8b7c0e6a5b..bb42c9ff9b 100644
--- a/flake.nix
+++ b/flake.nix
@@ -178,7 +178,7 @@
                   EOF
                 '';
                 # Start synapse when `devenv up` is run.
-                processes.synapse.exec = "poetry run python -m synapse.app.homeserver -c homeserver.yaml --config-directory homeserver-config-overrides.d";
+                processes.synapse.exec = "poetry run python -m synapse.app.homeserver -c homeserver.yaml -c homeserver-config-overrides.d";
 
                 # Define the perl modules we require to run SyTest.
                 #