summary refs log tree commit diff
path: root/docker/build_debian.sh
diff options
context:
space:
mode:
authorShay <hillerys@element.io>2022-03-29 18:22:38 -0700
committerDavid Robertson <davidr@element.io>2022-03-30 17:01:54 +0100
commitd820ff204b2125a9b9540e454f7e4508d645f0c2 (patch)
tree141b27cade27d2234c66b74e2820165f7594d15f /docker/build_debian.sh
parentBUILDS: `poetry` in Synapse docker image (diff)
downloadsynapse-d820ff204b2125a9b9540e454f7e4508d645f0c2.tar.xz
BUILDS: `poetry` in deb virtualenvs
Diffstat (limited to '')
-rw-r--r--docker/build_debian.sh3
1 files changed, 3 insertions, 0 deletions
diff --git a/docker/build_debian.sh b/docker/build_debian.sh
index 9eae38af91..5adfbb48ca 100644
--- a/docker/build_debian.sh
+++ b/docker/build_debian.sh
@@ -11,6 +11,9 @@ DIST=$(cut -d ':' -f2 <<< "${distro:?}")
 cp -aT /synapse/source /synapse/build
 cd /synapse/build
 
+# Export a requirements.txt file for the dh-virtualenv to use
+poetry export --extras "all test" -o requirements.txt
+
 # if this is a prerelease, set the Section accordingly.
 #
 # When the package is later added to the package repo, reprepro will use the