summary refs log tree commit diff
path: root/debian
diff options
context:
space:
mode:
authorAndrew Morgan <1342360+anoadragon453@users.noreply.github.com>2022-05-05 14:51:15 +0100
committerGitHub <noreply@github.com>2022-05-05 13:51:15 +0000
commite923fc20bda436a894301350ac9ab2b4bb942e18 (patch)
treeb75e1b30f10def80412cf9196ca45e805345be86 /debian
parentMove groups/communities deprecation notice to 1.58.0 heading (diff)
downloadsynapse-e923fc20bda436a894301350ac9ab2b4bb942e18.tar.xz
Include extra dependency groups 'systemd' and 'cache_memory' in debian packages (#12640)
Co-authored-by: Richard van der Hoff <1389908+richvdh@users.noreply.github.com>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/build_virtualenv7
-rw-r--r--debian/changelog7
2 files changed, 13 insertions, 1 deletions
diff --git a/debian/build_virtualenv b/debian/build_virtualenv
index b068792592..d2955f7628 100755
--- a/debian/build_virtualenv
+++ b/debian/build_virtualenv
@@ -37,7 +37,12 @@ python3 -m venv "$TEMP_VENV"
 source "$TEMP_VENV/bin/activate"
 pip install -U pip
 pip install poetry==1.2.0b1
-poetry export --extras all --extras test -o exported_requirements.txt
+poetry export \
+    --extras all \
+    --extras test \
+    --extras systemd \
+    --extras cache_memory \
+    -o exported_requirements.txt
 deactivate
 rm -rf "$TEMP_VENV"
 
diff --git a/debian/changelog b/debian/changelog
index 53b2387776..c828514752 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+matrix-synapse-py3 (1.58.0+nmu1) UNRELEASED; urgency=medium
+
+  * Include python dependencies from the `systemd` and `cache_memory` extras package groups, which
+    were incorrectly omitted from the 1.58.0 package.
+
+ -- Synapse Packaging team <packages@matrix.org>  Thu, 05 May 2022 12:26:36 +0100
+
 matrix-synapse-py3 (1.58.0) stable; urgency=medium
 
   * New Synapse release 1.58.0.