summary refs log tree commit diff
path: root/debian
diff options
context:
space:
mode:
authorДамјан Георгиевски <gdamjan@gmail.com>2019-02-14 14:44:22 +0100
committerRichard van der Hoff <1389908+richvdh@users.noreply.github.com>2019-02-14 13:44:22 +0000
commita214ba93e0770f87c1a13a62375a11fd6c60bf64 (patch)
treea6850004c7a5484780b8c5957691773fff403abe /debian
parent0.99.1rc2 (diff)
downloadsynapse-a214ba93e0770f87c1a13a62375a11fd6c60bf64.tar.xz
implement `reload` by sending the HUP signal (#4622)
* implement `reload` by sending the HUP signal

According to the 0.99 release info* synapse now uses the HUP signal to reload certificates:

> Synapse will now reload TLS certificates from disk upon SIGHUP. (#4495, #4524)

So the matrix-synapse.service unit file should include a reload directive.

Signed-off-by: Дамјан Георгиевски <gdamjan@gmail.com>

Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/matrix-synapse.service1
2 files changed, 7 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 04b5d69053..d4b9ed8ed7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+matrix-synapse-py3 (0.99.1) UNRELEASED; urgency=medium
+
+  * Added ExecReload= in service unit file to send a HUP signal
+
+ -- Damjan Georgievski <gdamjan@gmail.com>  Thu, 14 Feb 2019 12:53:13 +0000
+
 matrix-synapse-py3 (0.99.0) stable; urgency=medium
 
   * New synapse release 0.99.0
diff --git a/debian/matrix-synapse.service b/debian/matrix-synapse.service
index 2e9cd83b5f..942e4b83fe 100644
--- a/debian/matrix-synapse.service
+++ b/debian/matrix-synapse.service
@@ -8,6 +8,7 @@ WorkingDirectory=/var/lib/matrix-synapse
 EnvironmentFile=/etc/default/matrix-synapse
 ExecStartPre=/opt/venvs/matrix-synapse/bin/python -m synapse.app.homeserver --config-path=/etc/matrix-synapse/homeserver.yaml --config-path=/etc/matrix-synapse/conf.d/ --generate-keys
 ExecStart=/opt/venvs/matrix-synapse/bin/python -m synapse.app.homeserver --config-path=/etc/matrix-synapse/homeserver.yaml --config-path=/etc/matrix-synapse/conf.d/
+ExecReload=/bin/kill -HUP $MAINPID
 Restart=always
 RestartSec=3