summary refs log tree commit diff
path: root/debian/rules
diff options
context:
space:
mode:
authorAmber Brown <hawkowl@atleastfornow.net>2018-12-11 04:14:34 +1100
committerRichard van der Hoff <richard@matrix.org>2018-12-20 11:15:52 +0000
commitfd4070a85dc4ece77f2427b586c18bb1f4a04197 (patch)
tree2f10f1098e20c3a1c8d44d3bdee6da074665f7b5 /debian/rules
parent0.34.0rc2 (diff)
downloadsynapse-fd4070a85dc4ece77f2427b586c18bb1f4a04197.tar.xz
import from package-debian-synapse
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000000..ad0e95c83d
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+# This file was automatically generated by stdeb 0.8.2 at
+# Fri, 12 Jun 2015 14:32:03 +0100
+export PYBUILD_NAME=matrix-synapse
+%:
+	dh $@ --with python2 --with systemd --buildsystem=pybuild --no-guessing-deps
+
+override_dh_auto_install:
+	python setup.py install --root=debian/matrix-synapse --install-layout=deb
+
+override_dh_auto_build:
+
+override_dh_installinit:
+	dh_installinit --no-start
+
+override_dh_auto_test:
+	PYTHONPATH=. trial tests