summary refs log tree commit diff
path: root/debian/rules
diff options
context:
space:
mode:
authorRichard van der Hoff <1389908+richvdh@users.noreply.github.com>2021-10-27 18:06:32 +0200
committerGitHub <noreply@github.com>2021-10-27 17:06:32 +0100
commit576921c66a35fa1023f7e9baf97b6304ff463549 (patch)
tree7572b45e1d7aacee7edc0f1cee978548a15a4cb7 /debian/rules
parentFix URL preview errors when previewing XML documents. (#11196) (diff)
downloadsynapse-576921c66a35fa1023f7e9baf97b6304ff463549.tar.xz
Force deb compression with `xz`. (#11197)
Fixes a problem where `impish` packages could not be processed by `reprepro`.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 6 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index b9d490adc9..5baf2475f0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -51,5 +51,11 @@ override_dh_shlibdeps:
 override_dh_virtualenv:
 	./debian/build_virtualenv
 
+override_dh_builddeb:
+        # force the compression to xzip, to stop dpkg-deb on impish defaulting to zstd
+        # (which requires reprepro 5.3.0-1.3, which is currently only in 'experimental' in Debian:
+        # https://metadata.ftp-master.debian.org/changelogs/main/r/reprepro/reprepro_5.3.0-1.3_changelog)
+	dh_builddeb -- -Zxz
+
 %:
 	dh $@ --with python-virtualenv